::::: Welcome to Web Series Today "collaborative environment"
::::: Help get LGPedia back online!!!!! <== ACT TODAY!!!!!
::::: Welcome to new Web Series Today blog "authors". <= PLEASE READ CAREFULLY!!!


Friday, May 25, 2007

Something on LG15 Today blog is pegging CPU usage

I am viewing the LG15 Today blog with Internet Explorer, and noticed (I think starting yesterday, but possibly sooner), some REALLY slow performance loading webpages. I finally realized today that this happens when I have the LG15 Today blog open in a window while loading other sites (such as lonelygirl15.com abc.com etc.) in another window.

I checked my "Windows Task Manager" and the CPU is almost pegged near 97% + usage with this blog open in an iexplore.exe process, but drops down to a few percent as soon as I exit the blog.

So, in short, something on this page is executing and bogging down CPU. If you are seeing this effect, navigate away from the blog when you are not actually reading it, and we will work to remove whatever is causing this.

~ QtheC

EDIT: The problem seems to have been Internet Explorer specific (at least it did not affect Modelmotion using a Mac), and was isolated and removed. It seemed to be due to IE having trouble properly loading a scroll frame with a large amount of text in it. I documented the code change in a comment on the article, Loose Ends, so that if we find a better solution, we can restore the feature.

8 comments:

  1. Have you tested other blog pages.

    My suspicion is that it will be the RSS news feeds. Sometimes those take a while to load. So try one of the pages like the Talk to... page that does not have a news feed. And then try a page like the Maddison page that has a news feed.

    ReplyDelete
  2. Oh and while u are at it try Firefox. Its a better browser in the first place.

    ReplyDelete
  3. Interesting that you do not see a problem with on the mac. I found what I think is the problem, though I do not understand exactly why. The "Loose Ends" article has a scroll window. When I load LG15 Today, the scroll window in that article only partially loads now for some reason (the slider bar is nearly as large as the track - if that make sense). If I hold the scroll down button, it slowly works it's way down to the bottom of the text, with the slider bar getting thinner, and when it finally reaches the bottom (all the text loaded), the CPU usage drops from 97%+ to about 4%.

    It may be an IE thing, but I'm going to remove that scroll window until/unless we have a fix.

    ReplyDelete
  4. Just take it out of the frame and that will probably fix it.

    ReplyDelete
  5. Yep, that took care of it.

    ReplyDelete
  6. Looks like u already did that.

    Nice job of tracking down the problem.

    We have some great stories today!!!!!

    ReplyDelete
  7. Umm, I still have those problems with LG15today. I have huge trouble even loading single articles from it. It depends on where I am (connection speed) but if there was more to be done about it, I'd be glad.

    ReplyDelete




If you want to become an "author" on Web Series Today please read: http://tinyurl.com/becomeaWSTauthor

For more detailed information about Web Series Today please read: Web Series Today:

For other info contact: [email protected]



Join the discussion: http://www.tinyurl.com/webseriescommunity